当前位置:→ 股海网通达信公式 → 正文
  • 通达信MACD三背离公式 一个副图 2个选股源码

  • 相关简介:MACD三背离 文件包括:1个副图, 2个选股 公式 {MACD三背离} MACD2:=2*(MACD.DIF-MACD.DEA); STICKLINE(MACD2=0 AND MACD2REF(MACD2,1),0,MACD2,1.2,0),COLOR0000A5; STICKLINE(MACD2=0 AND MACD2REF(MACD2,1),0,MACD2,1.2,0),COLORAA7800; STICKLINE(MACD20 AND MACD2REF(MACD2,1),0,MACD2,

  • 文章来源:股海网发布时间:2020-01-21 22:09:23浏览次数:下载次数:0收藏:

MACD三背离

文件包括:1个副图, 2个选股 公式

{MACD三背离}

MACD2:=2*(MACD.DIF-MACD.DEA);

STICKLINE(MACD2>=0 AND MACD2>REF(MACD2,1),0,MACD2,1.2,0),COLOR0000A5;

STICKLINE(MACD2>=0 AND MACD2<REF(MACD2,1),0,MACD2,1.2,0),COLORAA7800;

STICKLINE(MACD2<0 AND MACD2<REF(MACD2,1),0,MACD2,1.2,0),COLOR00A500;

STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,1.2,0),COLORA500A5;

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:EMA(DIF,9);

MACD:(DIF-DEA)*2,NODRAW;

{MACD日线二次金叉}

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

DRAWTEXT(二次金叉,DEA*1.25,'零下二金'),COLORWHITE;

{MACD日线底背离}

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

DRAWTEXT(底背离,DIF*0.5,'日底背'),COLORRED;

{日底背画线:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,DOTLINE;}

{MACD日线顶背离}

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);

DRAWTEXT(顶背离,DIF*1.12,'日顶背'),COLORGREEN;

{日顶背画线:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,DOTLINE;}

{MACD_KDJ的金叉共振}

{DIF:EMA(CLOSE,12)-EMA(CLOSE,26);DEA:EMA(DIF,9);}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));

K:=SMA(RSV,9,3),NODRAW;

D:=SMA(K,9,3),NODRAW;

J:=3*K-2*D,NODRAW;

M&K金共:=CROSS(DIF,DEA) AND CROSS(K,D) AND CROSS(J,D);

DRAWTEXT(M&K金共,DEA*1.12,'金叉共振'),COLORYELLOW;

{MACD柱背离}

MACD高:=HHV(MACD,5);

C1:=BARSLAST(REF(CROSS(DEA,DIF),1));

E:=REF(C,C1+1)>C AND DEA>0 AND REF(MACD高,C1+1)<MACD高 AND CROSS(DEA,DIF) ;

DRAWTEXT(E>0,-0.5,'柱顶背'),COLORCYAN;

F:=REF(C,A1+1)>C  AND DEA<0 AND REF(MACD高,A1+1)<MACD高 AND CROSS(DIF,DEA);

DRAWTEXT(F>0,0.5,'柱底背'),COLORLIRED;

{MACD积背离}

JC:= DEA-DIF;

绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);

红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);

本次最低价:=LLV(L,BARSLAST(JC<0));

本次最高价:=HHV(H,BARSLAST(JC>0));

X1:=IF (MACD<0,BARSLAST(CROSS(DIF,DEA)),0);

前次绿柱面积:=REF(绿柱面积,X1+1);

前次最低价:=REF(本次最低价,X1+1);

Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);

RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价

AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

底背驰:= IF (CROSS(DIF,DEA),REF(Y1,1),0);

DRAWTEXT(底背驰,DEA*0.8,'积底背'),COLORFF80FF;

X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIF)),0);

前次红柱面积:=REF(红柱面积,X2+1);

前次最高价:=REF(本次最高价,X2+1);

Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);

RS2:= MACD>0 AND REF(MACD,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

顶背驰:= IF (CROSS(DEA,DIF),REF(Y2,1),0);

DRAWTEXT(顶背驰,DEA*0.8,'积顶背'),COLORCYAN;

{两个同时背离}

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

MACD高:=HHV(MACD,5);

F:=REF(C,A1+1)>C  AND DEA<0 AND REF(MACD高,A1+1)<MACD高 AND CROSS(DIF,DEA);

柱底背:=F>0;

JC:= DEA-DIF;

绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);

红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);

本次最低价:=LLV(L,BARSLAST(JC<0));

本次最高价:=HHV(H,BARSLAST(JC>0));

X1:=IF (MACD<0,BARSLAST(CROSS(DIF,DEA)),0);

前次绿柱面积:=REF(绿柱面积,X1+1);

前次最低价:=REF(本次最低价,X1+1);

Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);

RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价

AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

积底背:= IF (CROSS(DIF,DEA),REF(Y1,1),0);

AA1:=底背离 AND 柱底背;

AA2:=底背离 AND 积底背;

AA3:=柱底背 AND 积底背;

XG:AA1 OR AA2 OR AA3;

{三个同时背离}

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

MACD高:=HHV(MACD,5);

F:=REF(C,A1+1)>C  AND DEA<0 AND REF(MACD高,A1+1)<MACD高 AND CROSS(DIF,DEA);

柱底背:=F>0;

JC:= DEA-DIF;

绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);

红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);

本次最低价:=LLV(L,BARSLAST(JC<0));

本次最高价:=HHV(H,BARSLAST(JC>0));

X1:=IF (MACD<0,BARSLAST(CROSS(DIF,DEA)),0);

前次绿柱面积:=REF(绿柱面积,X1+1);

前次最低价:=REF(本次最低价,X1+1);

Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);

RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价

AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

积底背:= IF (CROSS(DIF,DEA),REF(Y1,1),0);

三背离:底背离 AND 柱底背 AND 积底背;

通达信MACD三背离公式 一个副图 2个选股源码

通达信MACD三背离公式 一个副图 2个选股源码

  • 下载资源所需积分

    0

  • 当前拥有积分

    0

股海网粉丝必读
公式解密、改选股联系QQ:78858997(有偿服务)点击查看详情...
股海网指标公式帮助使用说明!新手必读...
股海网新系统使用说明!新手必读...
股海网VIP用户组必读...
说说看法 0
推荐资源

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - SiteMap - TOP
Copyright © 2020 铭网科技,All Rights Reserved.湘ICP备09016573号-10
本站所有广告和与股海网均无关系,请股友自行判断真假!股海网客服QQ:78858997
股海网股票软件下载中心
股海网股票书籍下载中心 湘公网安备43108102000040号
二八杠洗牌顺口溜 如何赚钱发财的23种方法 一定牛天津十一选五 上海11选五4月3号 广东快乐十分稳赚计划 天津快乐10分钟软件 股票分析图 青海十一选五走势图基本走势 河北快三人工计划app 体彩天津11选5预测 st轻骑股票行情 股票配资平台l选一直牛 北京快3怎么下载 梦之城娱乐登录 今天上海时时乐开奖走势图 经典股票论坛 四川快乐12今天开奖结